Problem:
Stealth Professional stalls on the loading screen and will not continue after setting up to connect to Interactive Brokers.
Cause:
The TWS API is not installed on the system.
Solution:
To determine whether or not an API installation is the cause, check the application log file (instructions on opening the log file can be found here) and see if one or both of the following log items is present:
{Main:IBBrk:SFrm = COMException} Class not registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG))
{Main:IBBrk:SFrm = COMException} The application has failed to start because its side-by-side configuration is incorrect.
If either of these items is present, it is likely that the API is not properly installed. If this is the case, follow these steps to install the API: